[teqc] teqc +qc "invalid LLI" error

Jim Wright jwright at unavco.org
Mon Apr 4 13:22:36 MDT 2005


I've tried to reproduce this problem with the raw data from the receiver
that I have buffered here, as well as with the RINEX data from the
official PBO archives at ftp://data-out.unavco.org/pub/PBO_rinex/.  I used
a few days preceding and following the file in question.  I also pulled
this specific file from SOPAC.  In no case was I able to reproduce this.
It appears to have been a transient problem with the file in the SOPAC
archives.  Because we are retrieving data hourly from this and several
other Mt. St. Helens stations, it introduces a number of possible problems
in populating the archives.  We work hard to make sure the official PBO
archives at UNAVCO are current and correct, but unfortunately we don't
have the resources to extend that effort to other archives.

Jim Wright
PBO Data Flow/Archives Software Engineer


On Fri, 1 Apr 2005, Lou Estey wrote:

> Paul,
> 
> > I'm getting the following error when I run rinex files for PBO site p699
> > through teqc's qc lite:
> > 
> > 
> > teqc +qc -st 2005-03-31000000 +dh 24 p6990900.05o
> > 
> > qc lite>
> > teqc: teqc windowed: delta = 86400.000 secfailure to read "-2147467405.66148
> > 12657.39" on line 56 of "p6990900.05o"
> >         (invalid LLI (Loss of Lock Indicator): should be 0-7) ... exiting
> > 
> > 
> > The error only occurs if I include the -st and +dh arguments.  Can you
> > suggest a workaround?  The -st and +dh arguments are used in SCOUT
> > (http://sopac.ucsd.edu/cgi-bin/SCOUT.cgi) when qc'ing a file prior to
> > running it through gamit.
> > 
> > FYI, the file is available from the SOPAC archive at:
> > http://garner.ucsd.edu/pub/rinex/2005/090/p6990900.05d.Z; teqc version info:
> > 
> > version:     teqc  2002Mar14
> > build:       Linux 2.0.36|Pentium II|gcc|Linux|486/DX+
> 
> Well, there are a lot of mysteries here.  I downloaded the above
> Hatanaka-compressed file and decompressed it with crx2rnx ver.u.2.3beta.
> In doing so, line 56 doesn't contain the above line fragment, and,
> in fact, it occurs nowhere in the whole .05o file.  Running your command
> using the current development version of teqc (although on Solaris Sparc)
> produces normal results, but then again the phase values "fit" within the
> F14.3
> formatting; the phase value you reported "-2147467405.661" is F15.3 -- i.e.
> _not_ valid RINEX.  This looks like the phase-overflow that we were initially
> seeing in NetRS data.  This overflow has been corrected in NetRS firmware --
> though I don't if site p699 has the right rev of firmware for this or not --
> but it doesn't matter because the data was translated with version 2005Jan28
> of teqc which corrects the phase overflow even it's not corrected in the
> firmware.
> 
> Maybe the version of crx2rnx that you are using is bad.  What version of
> that are you using?
> 
> hth,
> --lou
> 
> _______________________________________________
> teqc mailing list
> teqc at ls.unavco.org
> http://ls.unavco.org/mailman/listinfo/teqc
> 


More information about the teqc mailing list