[teqc] Problems converting NetR9 T02 files to RINEX

boissier boissier at ipgp.fr
Tue Apr 24 03:27:24 MDT 2018


Hi Lou,

I will contact Trimble to help me on this case.
I'll post the results on the list.

Thanks for your help
Patrice


Le 23/04/2018 à 17:17, Lou Estey a écrit :
> Then it's time to contact Trimble support, since this is 100% a 
> Trimble issue.
>
> --lou
>
> On 23-Apr-18 07:10 AM, boissier wrote:
>> I just tried adding the options but it is still not working :
>>
>> $ runpkr00 -f -k2048 -g -d -v DSRG201804140000A.T02
>> runpkr00:  Version 5.40 (Linux)
>> runpkr00:  T01Lib: 8.63
>> runpkr00:  DAT: DSRG201804140000A.tg!
>> runpkr00:  Input file: DSRG201804140000A.T02
>> Segmentation fault
>>
>> Regards,
>> Patrice
>>
>> Le 23/04/2018 à 16:57, Lou Estey a écrit :
>>> Here at UNAVCO, our standard usage of Trimble's runpkr00 also 
>>> includes using
>>> '-f' and '-k2048'; see tip of the week 
>>> https://postal.unavco.org/pipermail/teqc/2017/002305.html
>>> Not that including these options will necessarily be the cure, but 
>>> you should at least
>>> try including them and report back.
>>>
>>> --lou
>>>
>>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>> Louis H. Estey, Ph.D.              office:  [+001] 303-381-7456
>>> UNAVCO, 6350 Nautilus Drive           FAX:  [+001] 303-381-7451
>>> Boulder, CO  80301-5554            e-mail:  lou  unavco.org
>>>
>>> "If the universe is the answer, what is the question?"
>>>                                                -- Leon Lederman
>>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>
>>> On 23-Apr-18 06:50 AM, boissier wrote:
>>>> Hi all,
>>>> A few weeks ago we started using the latest generation of Trimble 
>>>> NetR9 (with the latest Trimble firmware : 5.33). We have problems 
>>>> converting some "T02" files to Rinex.
>>>> Our scripts convert raw T02 files into an intermediate format (TGD) 
>>>> using the "runpkr00" utility. Then TEQC is used for TGD to RINEX 
>>>> conversion.
>>>> Some files are convertible in TGD and others are not:
>>>>
>>>> OK :
>>>> $ runpkr00 -v -g -d DSRG201804130000A.T02
>>>> runpkr00:  Version 5.40 (Linux)
>>>> runpkr00:  T01Lib: 8.63
>>>> runpkr00:  DAT: DSRG201804130000A.tg!
>>>> runpkr00:  Input file: DSRG201804130000A.T02
>>>> runpkr00:  records: 6676
>>>> runpkr00:  status : 0
>>>>
>>>> Not OK :
>>>> $ runpkr00 -v -g -d DSRG201804140000A.T02
>>>> runpkr00:  Version 5.40 (Linux)
>>>> runpkr00:  T01Lib: 8.63
>>>> runpkr00:  DAT: DSRG201804140000A.tg!
>>>> runpkr00:  Input file: DSRG201804140000A.T02
>>>> Segmentation fault
>>>>
>>>> I suspect that Trimble has added things in the T02 that causes an 
>>>> overflow in a buffer and thus a segmentation fault ...
>>>>
>>>> The problem is that I cannot find a newer version of runpkr00: the 
>>>> 5.40 version is the latest referenced on the UNAVCO website and the 
>>>> Trimble site does not seem to distribute this utility ...
>>>>
>>>> Has anybody experienced this problem?
>>>>
>>>> Thanks in advance!


-- 
---------------------
|       ,*-'.       | Patrice Boissier
|       .'+*        | Ingénieur d'Etudes - Développement d'applications
|     '   #   '     | Observatoire Volcanologique
|        /v\        | du Piton de La Fournaise
|      ,'  .`.      | Institut de Physique du Globe de Paris
| __.-"  ^    "-.__ | Tél : +262 262 27 58 26
--------------------- GSM : +262 692 70 38 56



More information about the teqc mailing list