Trimble t01 files failing to produce valid data.

John Hamilton hamilton at terrasurv.com
Thu Jun 9 13:05:18 UTC 2022


I believe the problem is with the receivers, the .t01 file does not appear
to contain any observations. I have seen files that were created and then
nothing was stored, they were of similar size.  I have several 5700's and
R7's, and have never seen that problem. It may be that the memory card is
full or faulty. Try formatting the cf cards using the trimble GPS
configurator utility. Also, I think there is a limit on the size of the
cards, I use 32MB cards, it may not work correctly with GB size cards

I am very familiar with the format of the .dat files, unfortunately I do
not have documentation for the .t01 files, I don't know of anyone outside
of Trimble who does. I don't really understand their need to keep the
format so proprietary.

On Thu, Jun 9, 2022 at 12:15 AM Camilo Rada <camilorada at gmail.com> wrote:

> Hi all,
>
> I need some advice from this community. I have over a dozen of Trimble
> R7 and a few 5700 receivers that form a long term monitoring network.
> While preparing 5 of them to be installed in a new location, I found
> that the .t01 data files they produce fails to generate a valid .dat or
> RINEX file. The five units have the same problem. I'm trying runpkr00
> (both linux v2.0 and windows v6.04), and it produces a very small DAT
> file, and with the -v option reports a status 29 or 30 (is 0 when all
> works). I've also tried the Trimble convert to RINEX utility (windows).
> I haven't been able to get the newer versions of this utility to work,
> but older ones produce an error "gps time of week out of range".
>
> I've also tried Trimble Online utility
> https://surveytools.trimbleaccess.com/gnssprocessor, and it fails with
> the error "Error: unable to convert to RINEX form".
>
> A few of the produced DAT files did produce a valid RINEX using teqc,
> but they contain only 3 to 10 observations where there should be
> hundreds of them. Most of the DAT files just produce empty observation
> files.
>
> My normal workflow is with runpkr00 (linux v2.0) and teqc, and that
> still works in older files produced by this very same receivers.
> Although, those files are also older than the last GPS week roll over.
> However, the firmware version is 2.32, which should handle the rollover
> correctly.
>
>
> I've attached an example of a .t01 file that is failing to convert to
> RINEX or DAT.
>
> Does anyone had a similar problem? Does it has to do with the receivers
> or the t01 to DAT conversion? Any known solutions or workarounds out there?
>
> There is nothing suspicious in the receivers behavior. They report that
> they are tracking satellites and logging data. I've tried with different
> antennas and antenna cables, and the problem persist. I've used the same
> CF card in all tests, but I doubt that could be the problem if the files
> get written successfully. Could it be?
>
> Thank you very much
>
> Camilo Rada



-- 
John Hamilton, PA PLS
Terrasurv, Inc
Pittsburgh, PA
Voice: +1-412-341-5620
Fax: +1-412-535-5185
File Transfer: terrasurv.wetransfer.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://postal.unavco.org/pipermail/teqc/attachments/20220609/932372cc/attachment.html>


More information about the teqc mailing list